New ChromiumOS Special Build Available!

Hi All

Its been a while (and thanks for being patient!) but I’ve just released a new special build at the following link: http://chromium.arnoldthebat.co.uk/special/Cx86OS_R41-6500.0-Special.7z

This should have much better support for Radeon which I’ve tested using a Dell Studio 1555:

  • Graphics – loads the Radeon Module (full 1920-1080 HD in this case) – working
  • Sound (Radeon HDMI) – working
  • Touchpad (Synaptics) – working
  • Intel Wireless – working

As for Radeon cards supported, the build should support all listed firmware here.

No Broadcom or other wireless drivers yet since these are for the next phase, but keep testing and feed back on what works or otherwise.

Happy testing!

77 thoughts on “New ChromiumOS Special Build Available!”

  1. Can you possibly build a version that can be installed using YUMI?

    It seems to me that ChromeOS is a bit harder to run and install in a USB than any other OS.

    I have 64 GB usb, with multiple linux distro, 3 different version of windows, zorin, and I would like to add ChromeOS if in there if possible, I been searching for everywhere and all the information I can find related to ChromeOS requires to format that USB stick which I really don’t want to do.

    Thanks

    1. The installation of ChromiumOS is simpler than you’re making it out to be. The USB disk image is a requirement from the Google source code…

      USB disks are like $10 US for 32Gb. My suggestion is you find a dual-pack of 16 or 8Gb USB’s and make one a 64-bit Chromium and the other a 32-bit Chromium disk.

      That way you’ll have everything sorted nicely. Linux on your YUMI disk and the two flavours of Chromium on the other two.

      I know this isn’t what you necessarily wanted but it’s an elegant option.

      1. I don’t know why but everytime I install ChromeOS on a USB, the USB is no longer readable by windows.

        and there are like 8 partition on the usb when I check using disk part

      2. Its pretty simple if you follow the standard installation, but finding a way to install it in a drive along with different OS or in a specific partition is a bit complicated

        1. İ am going to crazy my netbook is very slow even in ubuntu unity and i found hexxeh build doesnt work i searchhed for a month but i cant find anything then i found your build i asked 3-4 days ago and last week i have reaaly important exams and i can look bere once a day. over 3 days i am going to crazy please help me i am really sorry about that world

    1. Ok and i will try Bundgie desktop its very looks like chrome os or i can install Evolve OS (which comes with bundgie desktop)

        1. For now i am Using gnome metacity and its very fast on ubuntu 14.04 but niwhen i change to Compiz effects was very slow because i cant find my gma3600 driver and it uses my cpu . İ will continue with metacity

    2. You probably wrote the image to your USB the wrong way. Use the following terminal command, but BE CAREFUL TO USE THE RIGHT DISK or you’ll nuke your OS.. You have been warned.

      dd if= of=/dev/sdc
      The /dev/sdc bit is the most important, this is the USB drive you plugged in. You can check which device you need to use with dmesg and/or mount

      1. Correction, should be dd if=[path to image] of=/dev/sdc, I forgot I can’t use lesser-than or greater-than here.

        1. HEY! THanks! Its finally working with this script.

          I am on a NOBRAND CHINESE x64 PC. Its running celeron 1037u processor,.
          Running arnoldthebat x64 img from 3rd of december.

  2. Hi There,

    Thanks for this build, I installed it on my USB drive and seems to work fine, only issue is the mousepad is not working,

    I bet this is some kind of driver compatibility,

    Cheers

  3. I tried booting off of a USB with this image on a Dell Latitude E6520 in both UEFI and legacy modes – UEFI mode at least gets to the GRUB boot screen (though none of the choices work), but legacy mode doesn’t even get past the kernel decompression and boot before stopping at a black screen. To elaborate on the UEFI mode – local images A and B boot, but then a black screen with garbled artifacts is all they boot to; nothing past this stage from what I can tell. Verified images A and B just boot to black screens, nothing after that.

    1. Any chance you can get to text login? Ctrl-Alt-F2 should do it. Then get the output of dmesg & /var/log/Xorg.0.conf. That laptop also looks to have Intel GMA 3000 so Ill need to review that as well…

  4. I would love to see some updates that add support for the Surface Pro. With the changes in June making ChromeOS more usable with touch-screens, I’d really love to have my Surface running ChromiumOS with full support.

    https://www.ifixit.com/Teardown/Microsoft+Surface+Pro+Teardown/12842

    You can find all the components for it here. So far, with the nightlies, display is working right, but the magnetic snap-on keyboard isn’t being recognized adn seeing as I can’t connect to WiFi, I can’t test anything else.

    Hope this is handy for you, I’ll keep an eye out for updates!

      1. Hey there, thanks for replying.

        WIndows 8.1 reports the network card as a “Marvell AVASTAR 350N Wireless Network Controller”

        Further research states it is the “Avastar 88W8797” chipset.

        Hope this helps!

  5. I have tested this build on HD5850 and I am sorry to report that it does not work for me.

    It load the logo screen but will immediately spit out this:

    flashrom:2026 map pfn expected mapping type uncached-minus for [mem 0x00000000-0x00003fff], got writeback

    Not sure about this error but it hangs OS.

    1. OK, does it actually hang the OS or do you just get a black screen? Can you type Crtl-Alt-F2 to get to chronos login?
      If so, could you post the output of dmesg and /var/log/Xorg.0.conf to http://pastebin.com/ and pop the links here?

      You should be able to ssh from a separate machine if its on your network…

      1. Hello there, happy new year 🙂
        My 2 cents: Same error here on Asus Eeepc:

        flashrom:7245 map pfn expected mapping type unchached-minus for item [mem 0x000000000.0x00003fff], got write-back.

        1. Hey

          First of all thank you for making this possible 🙂

          I’m quite new to all this, but i’ve dual booted my laptop with Ubuntu succesfully. This however is giving me more trouble…

          I have an old dell vostro (AMD64) and tried installing the latest special build on it. I get the same error as above…
          Any progress on a fix?

  6. I am having a heck of a time getting my intel 5100 to work, I see it’s there and working but for some reason rfkill turns off the radio on boot. If I run dmesg it shows rf_kill bit toggled to disable radio

        1. Arnold, can we manual apply the broadcom wireless driver on you latest build? If yes could you give me a hint to start?

          The build boots fine from the USB pendrive, on Lenovo IdeaPad S10e A16-4068, Atom N270
          Ethernet is Fine, but wireless not
          Audio is a bit laggy, video on youtube runs fine up to 480p, but 720p is kinda laggy

          You are the best on Chrome OS support man!!! Merry Christimas !!!

          1. Yes of course you can. Ive not built a new wl.ko however since it keeps crashing the OS when applied as a module. I need to figure that bit out 1st! You can of course apply your own..

  7. Just a thank you from me. Would love to see the Broadcom drivers build when you get chance – but I imagine automation is higher on your list (rightly so)!

    Still running Dec 2013 Broadcome special build on HP Mini 110. FYI – The only downside is that Gmail moans about Chrome version and that it’s not possible to get Flash running on a old build, meaning Google Music won’t stream. Don’t stop the Mrs shopping, tho. 😉

    Thanks again, MrTheBat, much appreciate.

  8. Thx for the build, its worth-waiting for. It would be much better if you can merge this “special” edition to the build bot, or a new update channel for us.

  9. I don’t understand what I’m missing….

    I download the file from link, extracted with 7z, wrote with Win32 to USB….

    I can not get it to boot

  10. Not working on my Acer Aspire V5-123-12104G50nss with AMD Radeon HD 8210 nor on my early 2008 iMac 8,1 with ATI Radeon HD 2600 PRO graphics. 🙁

  11. When will there be a realtek RTL8723AE WLAN driver avalible, because I practically need ChromeOS on my Toshiba satellite C8551TC

      1. My wireless card is BCM4312, if the name is wrong the id is: VEN_ID: 14E4 / DEV_ID: 4515
        My Ethernet is: VEN_ID: 14E4 / DEV_ID: 1713

        On Special Multi 2, both don’t work, on latest daily builds R41 the ethernet works OOB

        The audio is a bit laggy (Realtek VEN_ID: 10EC / DEV_ID: 0269), but I’ve still hasn’t tried any tutorial, touch pad is crazy (became too sensitive that it appears to be like airview of galaxy note), but works, if I apply the fix for Snaptics, it became normal but without tap to click.

        My netbook is a Lenovo S10e 4068-A16, with Intel Atom 1.6 GHz, 2 GB of RAM (standard chip slot, my model don’t have the fixed 512 MB chip of S10 or S10-2), Video onboard Intel GMA 950 (GMA 945SE chipset underclocked to 166 MHz)

        If I can provide any kind of log to help, because the main stream of netbook’s around the world are the same Atom chipset.

  12. Found your site and wanted to try the install…Using a dell MINI 1018..
    I booted up on USB drive, when to shell, typed in:
    /usr/sbin/chromeos-install
    getting: initctil: unknown instance: Error can ot determine the destination device. Specify –dst yourself.
    I’m new to this, could be something simple…

      1. I wanted to say thank you! I am having success running the I am using a Dell D630. I am having success booting the os off the usb drive, but every time I try to install it locally with the command that is provide (/usr/sbin/chromeos-install -dst=/dev/sda). I receive a “flags:WARN getopt: invalid option –“d”
        Thank you in advance.
        Sincerely,
        Kannan

  13. Thanks for this special build!

    My wifi network controller is:
    – Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

    And copying the fw /lib/firmware/rtlwifi/rtl8192sefw.bin to same path from ubuntu installation works!

  14. I’m trying to run this special build on a lenovo t61. All seems ok, except there’s a display issue. The shelf appears ok and works fine (pop-ups, etc), and the background is fine (mostly) but where the window should be to login, weird black rectangles appear. I can connect to wireless by using the shelf, and CTRL-ALT F2 works for a prompt… Any idea what command I can enter to download usable display drivers? (I think this is the issue).

  15. Hi there, I tried the latest weekly build (Cx86OS-20150104010101) on an old Acer Aspire One (AOA150) and the WiFi does not seem to work. Pretty sure it has an Atheros card.

  16. Thanks for your work, serves me well, I have worked with in the studies.

    Currently I have a flash drive with the installed chrome os, but I would like pdoer install in vmware or virtualbox, but all my attempts to convert the .img to iso, or .vdi have failed, I could tell if there is any other way to create a virtual machine chrome os.

    or alternatively, upload a file exported from chrome os installed on the virtualbox? Thank You

Leave a Reply to Winand Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.