Chromium OS Special Builds

Chromium OS Special Builds are an enhancement to the default vanilla builds of Chromium OS to allow support for as many  devices as possible.

All downloads are located at http://chromium.arnoldthebat.co.uk/index.php?dir=special and will be updated as new functionality is brought into the build as well as regular maintenance releases to keep the UI up to date.

Two deployments are currently supported, x86 (32 bit) and amd64 (64 bit).They are based on the x86-generic and amd64-generic overlays but have the following additional support:

The builds also allow Over The Air (OTA) updates from dev servers. From the browser, just go to Settings > About > Check for and apply updates and magic will happen. Updates will be automatic for builds after R46-7323 and will allow for development tools update with a single shell command:

sudo stateful_update

Install is exactly the same as http://arnoldthebat.co.uk/wordpress/chromium-os/

Have fun testing and using it. Feel free to feedback with whatever isn’t working as expected and I’ll try to build in to the next release!

Known Issues/Bugs: https://github.com/arnoldthebat/chromiumos/issues


In addition to the Special Builds, there are now enhanced Vanilla builds. These allow Google Drive integration and certain enhanced media codecs. This should allow the users with working daily builds more functionality and usability.

These Vanilla builds will also update automatically as and when I get the Update Server ready.

Please do not log issues with the Vanilla build since they are a courtesy build and will only work on devices with Freon supported graphics and CMT supported touch pads. WiFi and Ethernet will also have reduced support.




563 thoughts on “Chromium OS Special Builds”

  1. Is there a special build for single board computers such as ASUS Tinker Board that supports Google Enterprise Enrollment?

      1. Hi can you Supports Asus VivoBook Model Tp201Sa
        some problems Touchpad andTouchScreen and wifi model
        qualcomm qca9377 driver plz

  2. hi! Bought a cheap YEPO 737A with UEFI (AMI) (Intel N3450 CPU with 64GB eMMC and additional 120GB SSD). intended to use as testbed for our company.

    Somehow we got it to work partially via USB boot, but we can’t seems to get it work after installed chromium OS on SSD, can’t boot at all.

    Wonder if there’s anyone having similar experience and know the workaround?

    thanks

    1. Hi!

      Managed to get Chromium OS to work on Yepo 737A under UEFI. However touchpad is not functioning.

      It seems that the touchpad will work after waking up from sleep, buttons and touch clicks still not working, only pointer movement is working. This does not happen eveytime, most of the time it just dont work.

      Learned that it may be bug in Linux kernel before 4.18. Wonder if I wanted to replace current CR 67 special build’s kernel, what should I do?

  3. Hi, after downloading and running from USB Everything seems to work fine but I can’t log in to my google account or anyone else’s for that matter. I can put my email address in and when it asks for my password it does show the correct avatar. I put in the password and it isn’t rejected, I just get a “please wait” and the spinning circle; I’ve left it for hours and I never can log in. I’ve also tried it on two other identical computers with the same results. I’ve installed Chromium OS and still get the same results.
    Computers are Lenovo R61i Thinkpads
    Build is Camd64OS_R67-10575.B-Special.7z

  4. I have R60-9592.B (Cx86OS) loaded on a Dell Inspiron Mini 1012 but can’t seem to get around an update required to use Google Play Store (notification states to log off and back in to resolve which doesn’t seem to work).

    Is there an update planned for the Cx86 platform or perhaps a work around available to get Google Play Store functional?

    1. Google Play Store isnt working right now.

      Also, no more updates are planned for Cx86 since its been removed by Google for support. Its far too complex and time consuming to keep it running.

  5. Hey arnold! thank you very much for your builds, especially those special builds run really well on my 2in1 convertable besides one problem. I don’t know if it’s related to the ISO but when I put this ISO on a 16GB USB stick and install chromium os on my laptop using “sudo /usr/sbin/chromeos-install –dst /dev/sda”, then apparently my sda3 and sda5 partitions will be too small to copy data from recovery images. My sda5 partition is for example 2GB which is too small because the recovery image contains like 2.1-2.4GB. There are plently of tutorials to upgrade chromium to chrome but no one tells that these partitions are too small for some reason. Is there something you or I can do about it?

    regards

  6. Hello.

    On both the special and daily builds, my microphone is detected (I can view and change the sliders in alsamixer, and lspci shows the audio device), but it does not pick up audio.

    In alsamixer, it’s listed as “HDA ATI SB”, and in lspci, it’s “00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)”.

    Also, microphones plugged into the mic jack do not work, but USB mics work.

    Was wondering if there’s something I could do to get it to work. If not, that’s fine. Everything else works wonderfully, though.

  7. i installed th R69 on my toshiba satellite C850 everything work. Except the play store
    I’m waiting for the next version with play store

  8. Whoops. Posted in a comment wall for an older build. Internal mic and mic jack are not working. Card is “HD ATI SB”, chip is “Conexant CX20590”. USB mics work. Turned up the controls in alsamixer, but the mic does pick up anything.

  9. Hello, I can’t find x86 version after August 2017 of this build, will you plan to build/upload one soon or should I try to force an amd64 one to boot on my 32bit only uefi tablet ?

  10. Hello, thank you so much for your work you literally saved my Chromebook Pixel after it has reached EOL. But I have couple of problems. The first one, when I insert my headphones the sound still comes out of my laptop speakers even though it does recognise the fact that headphones are plugged in. The second problem is small but really annoying, when i put two finger on my touchpad the page starts flicker up/down.

    Can I integrate drivers from my original recovery image? I’ve tried to copy firmware and modules folders from original image to my lib folder but it doesn’t work as expected.

      1. Thank you, for your reply. Yes, it’s my chromebook. I’ve partially solved audio problem by unmutting headphones channel in the alsa-mixer though headphones sound is extremely loud. But the main problem is touchpad. I’ve tried to use atmel’s mxt-app utility to export/import touchpad settings but unfortunately it doesn’t help. If I understand correctly I should find somewhere the source code of my drivers and try to compile it with kernel-4.4 headers. Or maybe it’s the problem with the firmware? But I’ve tried to copy firmware folder from the original recovery.

      2. What’s interesting, running original chrome os image lsmod | grep atmel doesn’t show atmel’s driver but
        cat /proc/bus/input/devices shows
        I: Bus=0018 Vendor=0000 Product=0000 Version=0000
        N: Name=”Atmel maXTouch Touchpad”
        P: Phys=i2c-1-004b/input0
        S: Sysfs=/devices/pci0000:00/0000:00:02.0/i2c-1/1-004b/input/input8
        U: Uniq=
        H: Handlers=event8 cpufreq_interactive
        B: PROP=5
        B: EV=b
        B: KEY=e520 10000 0 0 0 0
        B: ABS=671800001000003

  11. Tried using CSM (legacy BIOS, secure boot off) on my Asus ROG GL702VM to boot the latest amd64 variant special build, and syslinux hangs at “booting Linux” as shown here: https://photos.app.goo.gl/gABStB5M8Y4S7HsU7

    The alt + print screen (magic SysRq key) didn’t work to force it to reboot. Is it even possible for the builds to boot?

  12. When installing on a Asus R209HA I can’t turn on Wifi. On Xubuntu I can use Wifi.

    Does Chromium works on a Asus R209HA?

  13. works very well, but touch not working. there is no serial_core or 8250 in kernel needed for serial wacom, i tried another version of chromium it was not as good but had these kernel drivers, i then added inputattach and touch worked well. any chance you could add these drivers to your kernel?

  14. Hello Arnold,
    Many thanks for your efforts. I am wanting to transform an old, 32bit lenovo netbook (S10) into a chromebook. I see that there is a special build version available that was released on August 28th 2017 (Cx86OS_R60-9592.B-Special). Are we getting a more updated version this year? Please advise,
    Many thanks

  15. I’m new to Chromium OS and I was wondering what could be the issue that prevents me from media playback Youtube, Facebook, Spotify, etc… Also I looked for disable hardware acceleration but boot flag screen was blank.

  16. Hey There,

    I’ve spent months trying to get every single combination of OS that is available to work on these Aspire One D270, I read people were able to get it’s processor to work no problem. I only see the Chromium logo (and animation) but after that it is frozen stiff, no terminal commands, nothing. Again I’ve tried over 6 of the vanilla build, special build and the one labeled CarmOS. Nothing has worked. Any suggestions?

  17. Thanks for your awesome work!
    So far I have two issues:
    – I2C Trackpad is detected as a mouse, which is annoying since it doesn’t support tap to click
    – Internal storages are not being mounted when installed on HDD (multiboot)

    I hope you’ll add necessary drivers to support I2C Trackpads.

  18. On my old laptop linux support does not work, but i can live with that.
    Biggest problem is alps touchpad, it is Alps AlpsPS/2 already mentioned on github id is:”Input device ID: bus 0x11 vendor 0x2 product 0x8 version 0x200″
    I tried to edit files in /etc/gestures, add LIBINPUT_EVENT7=yes in /etc/chrome_dev.conf, but no luck.
    Is this solved and do i missing something 🙂

  19. Hey mate, I’m just delving into the world of Chromium OS – I recently got a Dell Venue 11 Pro. Tried Cloudready OS and it worked treat.
    Unfortunately I couldn’t get any newer special builds from your website working. Eg the R69 builds.
    I did get an R65 build working though.
    Do you know why the newer build wouldn’t boot at all? Just goes to a blank screen, and can’t get to the terminal with the F2 key combo.

  20. the latest 64 bit special build keep crashing after its been to sleep about a minute after waking.

    any idea what could be causing this?

  21. HI Arnold

    Love your work

    My Asus ux305 laptop is freezing once i wake it from sleep.

    I’m using the latest special build I’ve tried others, any idea what could be causing this?

    everything else works perfectly!

    Thanks

  22. New special build (R73?) coming soon? I tried the exton build and the performance is 100x better and the on screen keyboard is WAYYY better, but no wifi on his build…

        1. Do you know if i update to the official “Nocturne” image after you release r71, will Android/logon things functuion properly as they do with the current “eve’ release?

  23. How can I build and install a custom kernel or kernel modules ? It seems I’m missing an Apple SPI module which is why neither the keyboard nor touchpad are working on a 2016 MacBook. Other than that minor inconvenience, it works beautifully. Thanks for your amazing work.

    1. You can build kernel modules outside of the OS so long as kernel you compile against matches the OS version. You should be able to do the same with a full kernel but Im not sure on the mechanism to update the ChromiumOS kernel with a new one. What you are asking for is fairly complex (I dont know your skill set) and would be better with a bespoke build. If you want to lend me a MacBook, Ill certainly have a crack at it! 😉

      1. Hi. Touchpad and WiFI works correctly on the latest CloudReady r70 build for Macbook late 2013 13″ Is it possible to reuse kernel modules of entire kernel form Cloudready build ?

      2. So I built the vanilla linux kernel, added in the drivers and then copied over the modules but the symbols were different. When I copied them all over and the new kernel it worked, however, the VM’s stopped working crostini and Android. So either I’ve missed some specific config or modules or, ChromeOS actually patches the kernel source and I’m missing those patches. I think it’s most likely the latter as I read more about chromium. So I probably need to build the kernel within the chromium build and not just independently.

  24. Arnold, first of all, thank you so much for your work here! Secondly, can you let me know if there is a particular build that will work with a Dell e5420 laptop? I’ve tried quite a few and cannot find one that enables the wifi.

      1. Its an i5 2520M based laptop. Has an Intel Centrino Ultimate-N 6300 802.11a/b/g/n wireless network adapter, and this is where I am having issues. I cannot seem to find a build that sees that wifi card.

        1. Just tried the latest R72 Vanilla. What happens is that when I try to turn the setting for wifi to ON, it automatically reverts to off.

  25. I have a dell latitude 6220 it runs the vanille custom r69 image from ssd but is there a ETA on the playstore fix would be great tot have it werking

    Will try to installatie it on a w700 tab if Windows 10 wont run normaly on it

  26. R72 vastly improved rendering performance for me, in R69 heat death of the universe would come faster than end of MotionMark 1.1, Youtube was dropping frames, mouse movement was jarringly sluggish and the UIn laggy.
    It’s amazing now. [ Cherry-Trail, Broadwell, Core M-5Y70, HP envy x2 13 ]

  27. Thanks for these builds! I’m trying to get things working on some odd hardware (Lenovo ThinkPad 10), and finding a few missing bits within R72 special, but they do seem to be options within the 4.14 kernel. Is there a way to bring back broadcom wireless (brcmfmac), and potentially add atomisp and the rt5672/rt5645/rt5640 sound codecs?

      1. The only unfortunate issue with your decision is that now the Broadcom SDIO cards don’t get detected at all. In particular, the card in question is a BCM43241 rev. b5. I depend on the brcmfmac driver getting loaded.

  28. Just tried the latest daily build with etcher and win32disk imager
    But booth ways i cant get it to boot.
    On a acer W700 and my dell latitude.
    In legacy mode i get error saying something about efi mode.

    The special vanilla image boots perfectly on booth methodes but cant update the R69 on the latitdu to R71 have already raised an isue on gituhb.

    Stateful_update errors out with unxpected end of file 2 times then quits and the omaha update give back an unxpected http responce 37 error.

    The dell will be on R69 untill the update option works.

    The daily is from today i tried but cant seem to figure out why it wont boot that and will boot the special R69 C64 img i have as fall back image.

  29. I have noticed some incosistencies with the EFI partitions of the normal daily builds and the specials.

    The normal dailybuilds have a complete empty EFI partition
    The specials hav an EFI partition with holds the EFI boot cfg for the loader and the images the bootloader chacks for.

    Maybe that could be the problem the normal daily builds wont boot the bios cant find the EFI boot files but finds the EFI partition so i can pointa boot order record to it but because there are no files there the system cant boot from the USB drives.

    1. Hi Arnold,

      Before proceed with my tangent Tycoon tablet ( Intel Atom N450), hier can I verify that I can install a 64 version of tour build ?

      Because its seem that when I boot on my key with 64, I stuck on black screen ?

      Thank you

  30. Hi Arnold! I have an old SL510 with Centrino that I’ve installed the Cx86OS onto. Works great, but for that it kicked out the drivers for the onboard keyboard and mouse! Where would you recommend I pull those?

  31. I am using the special build of Chromium 72, and there is no way to access my Google Drive. Is there any way to solve this problem?

      1. Is there any update on this? The usb port on my Pro died and now I can’t use a usb adaptor. I just have a paperweight now.

        Thanks in advance (with either outcomes)!

  32. Could you add support for Samsung Galaxy TabPro S wifi adapter Qualcomm Atheros QCA61x4A wifi adapter…I have tried v69 special and vanilla build and v72 special and vanilla builds…

  33. What can I do if I get WiFi-problems. When I turn on WiFi, it just switch off! It seems that I have some driver problems. So how can I install WiFi-drivers manually?

    I’m running the Asus T100HA.
    In Linux, I have the same problem and I run this command: “cp /sys/firmware/efi/efivars/nvram-* /lib/firmware/brcm/brcmfmac43340-sdio.txt” and then “modprobe -r brcmfmac” “modprobe brcmfmac”. After that, Wi-Fi works!

    I tried adding the brcmfmac43340 to that folder in the chromium USB-folder but I couldn’t get it to work.

  34. Thanks for the amazing work!
    Has anyone here experience in making the builds run on 2013 MacBook Pro? I tried a couple of builds but wifi is not running

  35. When I boot from the USB and select local image A I get stuck at “booting local image A”
    I’ve got An i7-8700k and a GTX 1070 Ti on a MSI z370 gaming pro carbon motherboard
    Can anyone help me, please?

  36. Thank you for all the work you put into these!

    Ive installed the special build on a pretty broad range of hardware, and so far the only real issue I had was with wireless on a 2010 macbook pro, it worked fine in windows and osx (quad boot setup) but this and kubuntu could only use ethernet. I didnt put much effort into fixing it though, I was mostly just testing.

  37. Hi, I am trying to boot into chromium on a RCA w122sc24t2 but I am having issues. When I try to boot, I get as far as seeing a black screen with a cursor but it doesn’t even flash once before it appears to freeze. I have tried the most recent daily, vanilla build, and special build with no luck on any of them. This tablet has a Celeron n4000 with Intel hd 600 and 2gb of ram. I have confirmed that this device can boot x64 OSes by booting into Ubuntu and Manjaro with grub functioning just fine.

    1. It turns out this is a. Issue with the version of grub as pointed out in a bug report on the GitHub.

  38. Hi I installed chromium on an Acer Aspire E5-574G-50JH notebook but the wifi does not work. I have a Qualcomm atheros NFA435 wifi card. How do I solve it? How can I add drivers manually? With Cloudready and fydeos, WiFi works.
    Thank you

      1. Thanks for these awesome builds! Working almost 100% on an Acer E5-473T-3860 except for this same wi-fi card issue. Card is also an Atheros QCNFA435 and the Bluetooth feature of it shows up as active, but trying to turn Wi-Fi on in Chromium results in the toggle turning right back off.

  39. I experienced the secondary display being too bright / too much contrast issue and I think I have an idea of the problem. I modified the resolution and it seems to have something to do with the refresh rate. Any refresh rate other than 60Hz is fine. But the 16:9 resolutions @ 60Hz are not working right. Perhaps the default should be 59Hz or 29.97Hz?

  40. Thanks for your hard work !

    Tested on a Surface Laptop 2, Internal Keyboard not working. Is there a workaround ? Thanks !

Leave a Reply to Peter Edwards Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

The general witterings of a nerd